Skip to content

Check Supported Radios

Below is a list of EdgeTX-compatible radios and their level of support.

Officially Supported Radios

The development and support for EdgeTX is conducted by the EdgeTX core development team with the support of developers from the community. Firmware for these radios is included in the main EdgeTX codebase.

  • Flysky NV14 (since v2.5)
  • Flysky EL18 (since v2.8)
  • Jumper T-Lite / T-Lite v2 (since v2.4)
  • Jumper T-Pro (since v2.6)
  • Jumper T-Pro v2 (Planned 2.10 for full support)* Current firmware available here.
  • Jumper T12 / T12 Plus / T12 Pro Hall (since v2.4)
  • Jumper T14 (Planned 2.10 for firmware, Companion to follow)* Current firmware available here.
  • Jumper T15 (since v2.10.1)
  • Jumper T16 / T16 Plus / T16 Pro Hall (since v2.4)
  • Jumper T18 / T18 Lite / T18 Pro (since v2.4)
  • Jumper T20 (Planned 2.10 for full support)* Current firmware available here.
  • Jumper T20 V2 (Planned 2.10 for full support)* Current firmware available here.
  • RadioMaster Boxer (since v2.8.1)
  • RadioMaster MT12 (Planned 2.10 for firmware, Companion to follow)* Current firmware available here.
  • RadioMaster Pocket (Planned 2.10 for full support)* Current firmware available here.
  • RadioMaster T8 Pro (since v2.4)
  • RadioMaster TX12 (since v2.4) / TX12 Mark II (since v2.8)
  • RadioMaster TX16S / RadioMaster TX16S MAX / RadioMaster TX16S Mark II (since v2.4)
  • RadioMaster Zorro (since v2.6)

Manufacturer Supported

The development and support for EdgeTX is conducted by the hardware manufacturers themselves. All changes made by the manufacturer are then submitted for review and inclusion into the main EdgeTX codebase.

  • iFlight Commando8 (since v2.8)
  • BetaFPV LiteRadio3 Pro (since v2.8)

Not supported by the EdgeTX Team - Community supported only

The development and support for EdgeTX is conducted by other interested 3rd parties from the community. Changes can be proposed as pull-requests to be considered for inclusion into the main EdgeTX codebase.

  • Eachine TX16S (since v2.4)
  • FrSky QX7 / QX7S / QX7 ACCESS / QX7S ACCESS (since v2.4)
  • FrSky X9 Lite / X9 Lite S (since v2.4)
  • FrSky X9D / X9D+ / X9D+ SE (since v2.4)
  • FrSky X9D+ 2019 / X9D+ SE 2019 (since v2.4)
  • Frsky X9E / Frsky X9E Hall (since v2.4)
  • FrSky X10 / X10S / X10 Express / X10S Express (since v2.4)
  • FrSky X12S / X12S-IRSM (since v2.4)
  • FrSky X-Lite / X-Lite S / X-Lite Pro (since v2.4)

*Note: To better support the manufacturers' release timelines, the manufacturers' can release an EdgeTX-supported radio with a "ready for manufacture" version of EdgeTX that has been developed in collaboration with the EdgeTX team that has not yet been merged into the main codebase. As a result, this firmware will not be available in EdgeTX Buddy or EdgeTX Companion until the next minor EdgeTX release.